emblem-important-2-24.pngLa version 7.1 étant proche de sa fin de vie, en décembre 2019, une mise à jour vers une version supérieure est conseillée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

Installation en parallèle, en Software Collection de PHP 7.3 (x86_64 uniquement) :

yum install php73

Remplacement du PHP par défaut du système par la version 7.2 (le plus simple) :

yum-config-manager --enable remi-php72
yum update

Installation en parallèle, en Software Collections de PHP 7.2 (x86_64 uniquement) :

yum install php72

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-7 sont construits avec RHEL-7.6
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5 (version 6.9.3, au lieu de la version embarquée)
  • l'extension oci8 utilise désormais le client Oracle version 19.3 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php71 / php72 / php73)