emblem-important-4-24.pngThe repository provides development versions which are not suitable for production usage.

Also read: PHP 7.4 as Software Collection

emblem-notice-24.pngInstallation : read the Repository configuration and choose installation mode.

Replacement of default PHP by version 7.4 installation, module way (simplest way on Fedora and EL-8):

dnf module disable php
dnf module install php:remi-7.4
dnf update

Replacement of default PHP by version 7.4 installation, repository way (simplest way on EL-7):

yum-config-manager --enable remi-php74
yum update php\*

Parallel installation of version 7.4 as Software Collection (x86_64 only, recommended for tests):

yum install php74

emblem-important-2-24.pngTo be noticed :

  • EL7 rpm are build using RHEL-7.6
  • EL6 rpm are build using RHEL-6.10
  • lot of extensions are also available, see the PECL extension RPM status page
  • follow the comments on this page for update until final version.

emblem-notice-24.pngInformation, read:

Base packages (php)

Software Collections (php74)